Connect with us

Gravity Forms 2.5.10

Brand New Release: Gravity Forms 2.5.10

Published

on

Gravity Forms 2.5.10


Gravity Forms 2.5.10 We are pleased to announce the release of Gravity Forms 2.5.10. With this latest update you will find a number of additions and fixes, including support for WordPress 5.8.1 (and above). Changes include…

  • Fixed an issue with our block script loading that breaks the Gutenberg editor in WordPress 5.8.x and up.
  • Updated the UI of the update button in the form editor.

Update to Gravity Forms 2.5.10

Check out this advice for updating to Gravity Forms 2.5.10…

  • How to Update Gravity Forms – If you are already using Gravity Forms version 2.5 (or above) and have background updates enables, 2.5.10 will update automatically. However, if you are yet to install Gravity Forms 2.5, you will need to do so manually. You can do this by either updating Gravity Forms from your site’s plugin page within WordPress Admin or downloading 2.5.10 from your Gravity Forms account dashboard.
  • Clear Your Cache – Caching and script optimization plugins and services have been known to cause problems with the functionality of forms when Gravity Forms is updated to the latest version. To counter this issue, we recommend clearing/flushing the caches and the browser cache following all updates.
  • Further Resources – For more information on 2.5, and to get the most out of this major update to our form builder, check out the Gravity Forms 2.5 Resource Hub.

Have any questions about Gravity Forms? Contact our friendly and knowledgeable Support team – they are always happy to help!

Gravity Forms 2.5.10 Changelog

  • Added alt text and title attribute for accessibility to the date field datepicker field icon.
  • Fixed an issue where the form button text doesn’t properly update for page conditional logic.
  • Fixed an issue where forms with pricing fields throw PHP notices if fields are removed before the form is rendered.
  • Fixed an issue with our block script loading that breaks the Gutenberg editor in WordPress 5.8.x and up.
  • Fixed an issue that causes some screens in the admin to have JavaScript errors in WordPress versions previous to 5.0.
  • Fixed an issue which causes field calculations with references to the calculated field to infinitely loop.
  • Fixed an issue that causes the Form Switcher to break on certain Admin views.
  • Fixed an issue which causes fields with multiple inputs to have incorrect aria-validate attributes.
  • Fixed an issue for the conditional flyout logic where checkbox and radio field based conditionals are not being respected.
  • Fixed an issue which causes fields with whitespace to break certain Add-on Feeds.
  • Fixed an issue where the border for the section field type is missing for the frontend form display when legacy markup mode is not enabled.
  • Fixed an issue for the generic map settings field not rendering when editing an existing feed where the setting was previously configured.
  • Fixed an issue that causes gfCalc events to be bound to the same listener multiple times.
  • Updated the reCAPTCHA settings link for the Captcha field “To use the reCAPTCHA field” message in the form editor.
  • Updated the UI of the update button in the form editor.
  • Updated the feed settings to run on admin_init instead of init to ensure they never trigger on the front end.
  • Updated some instances of strings not being translatable for the System Status view.

Gravity Forms 2.5.10 API Changelog

  • API: Fixed an issue where field map fields don’t auto populate with default options.

 

Gravity Forms Newsletter

If you want to keep up-to-date with what’s happening on the blog sign up for the Gravity Forms newsletter!

Share This






Source link

Continue Reading
Click to comment

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.